Support Unavailable
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted May 17, 2019 - 12:00 PDT
Investigating
Due to Salesforce outage, email and live agent support is currently unavailable.
Posted May 17, 2019 - 10:24 PDT