GetFeedback Site Intermittently Unavailable
Incident Report for GetFeedback
Resolved
The issue has been resolved. We'll continue to monitor and update here if any further issues arise.
Posted over 1 year ago. Jan 04, 2018 - 14:16 PST
Monitoring
A small percentage of GetFeedback traffic is currently failing due to issues in our platform provider. Our platform provider has identified the issues and is working on a fix. Until then, some users and survey takers may experience intermittent difficulty loading GetFeedback pages. If you are experiencing this issue please try refreshing the page as it will allow it to load on most second attempts. We'll update here as soon as more information becomes available. Thank you for your patience!
Posted over 1 year ago. Jan 04, 2018 - 12:49 PST