The GetFeedback blog is currently down.
Incident Report for GetFeedback
Resolved
This incident has been resolved. Our blog is back up-and-running.
Posted 5 months ago. Jan 10, 2019 - 10:08 PST
Investigating
We are looking into a fix for this interruption.
Posted 5 months ago. Jan 10, 2019 - 10:00 PST
This incident affected: Marketing Site.