GetFeedback site temporarily unavailable
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 13:25 PDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2021 - 13:24 PDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2021 - 13:06 PDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2021 - 13:04 PDT
Investigating
GetFeedback is experiencing service interruption. Our engineers are working actively to investigate and restore service.
Posted Apr 14, 2021 - 13:02 PDT
This incident affected: Survey Builder & Administration, Live Surveys, and Salesforce API Integration.