Loading issues with results and dashboards

Incident Report for GetFeedback

Resolved

The issue has been resolved and results are available to view.
Posted Jul 23, 2024 - 14:39 PDT

Investigating

We are investigating an issue with results and dashboards not loading in the GetFeedback platform.
Posted Jul 23, 2024 - 11:04 PDT
This incident affected: Survey Builder & Administration.