This incident has been resolved as we are no longer seeing direct impact to our services. Please be aware that AWS may still be having some intermittent issues though.
Posted Oct 20, 2025 - 12:34 PDT
Update
Due to an ongoing AWS issue (which can be monitored at https://health.aws.amazon.com/health/status), there is a significant portion of GetFeedback Direct and Digital users that cannot access the site (i.e. encountering 500 error).
Posted Oct 20, 2025 - 09:24 PDT
Monitoring
Due to an ongoing AWS issue (which can be monitored at https://health.aws.amazon.com/health/status), there is a significant portion of GetFeedback Direct and Digital users that cannot access the site (i.e. encountering 500 error).
Posted Oct 20, 2025 - 07:55 PDT
This incident affected: Survey Builder & Administration, Live Surveys, Salesforce API Integration, Email Deliverability, Payment Gateway, GetFeedback API, GetFeedback Digital (formerly Usabilla) for Websites, GetFeedback Digital (formerly Usabilla) for Apps, GetFeedback Digital (formerly Usabilla) For Email, and GetFeedback Workspaces.