GetFeedback Digital Web Campaigns not displaying

Incident Report for GetFeedback

Resolved

This incident has been resolved. Web campaigns are displaying again without any errors.
Posted Jul 05, 2024 - 03:51 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 04, 2024 - 08:15 PDT

Investigating

We are currently investigating this issue.
Posted Jul 04, 2024 - 07:17 PDT
This incident affected: GetFeedback Digital (formerly Usabilla) for Websites.