Loading issues with results and dashboards
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted Aug 13, 2024 - 11:51 PDT
Investigating
We are investigating an issue with results and dashboards not loading in the GetFeedback platform.
Posted Aug 13, 2024 - 11:41 PDT
This incident affected: Survey Builder & Administration.