GetFeedback Direct maintenance

Scheduled for Nov 18, 01:00 - 02:00 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 11, 2025 - 13:13 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 11, 2025 - 13:04 PST

Scheduled

All services for GetFeedback Direct will be temporarily unavailable, including data collection and API access, during this scheduled maintenance.
Posted Nov 11, 2025 - 13:02 PST
This scheduled maintenance affects: Survey Builder & Administration, Live Surveys, Salesforce API Integration, Email Deliverability, and GetFeedback API.