Dashboards failing to load
Incident Report for GetFeedback
Resolved
This issue has been resolved. Dashboards and survey responses are now loading.
Posted Aug 29, 2024 - 12:15 PDT
Identified
We're currently experiencing issues with the dashboards loading for GetFeedback Direct. Users won't be able to view responses on their dashboards at this time.
Posted Aug 29, 2024 - 11:49 PDT
This incident affected: Survey Builder & Administration.