GetFeedback Direct (https://app.getfeedback.com/) is down

Incident Report for GetFeedback

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 19:15 PST

Monitoring

GetFeedback Direct (https://app.getfeedback.com/) appears to be loading correctly now. However, the third-party has not given an all clear on their outage. As such, we're continuing to monitor this incident.
Posted Feb 17, 2026 - 18:45 PST

Identified

The issue has been identified. It was caused by an outage at a third-party. They are aware about the incident and are working towards resolving the issue, but as the issue was caused by a third-party outage, we unfortunately don't have an ETA.

Notably, respondents should still be able to access and complete GetFeedback surveys.
Posted Feb 17, 2026 - 18:03 PST

Investigating

We are currently investigating this issue.
Posted Feb 17, 2026 - 17:33 PST
This incident affected: Survey Builder & Administration.