GetFeedback dashboards unavailable
Incident Report for GetFeedback
Resolved
This incident has been resolved and dashboards are now available.
Posted Oct 25, 2023 - 11:53 PDT
Investigating
There is an in-progress update impacting the ability to view dashboards in GetFeedback. Investigation is underway.
Posted Oct 25, 2023 - 11:04 PDT