http://getfeedback-cx.com/ survey links are not accessible

Incident Report for GetFeedback

Resolved

This issue has been resolved.
Posted Feb 20, 2025 - 09:25 PST

Update

http://getfeedback-cx.com/ survey links, commonly sent through email campaigns, are inaccessible. We've taken the necessary steps on our end to address the issue, but full resolution requires action from a third party. We'll update here once the issue has been completely resolved.
Posted Feb 19, 2025 - 20:20 PST

Monitoring

http://getfeedback-cx.com/ survey links, commonly sent through email campaigns, are inaccessible. We've taken the necessary steps on our end to address the issue, but full resolution requires action from a third party. We'll update here once the issue has been completely resolved.
Posted Feb 19, 2025 - 18:30 PST
This incident affected: Live Surveys.