Error when logging in to GetFeedback Direct Account

Incident Report for GetFeedback

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 18:04 PDT

Monitoring

We have started to see some recovery in services with our provider. Please try logging in again. We'll continue to monitor the situation and update accordingly.
Posted Jun 10, 2025 - 16:08 PDT

Identified

This issue is being caused by an outage with one of our downstream providers.
Posted Jun 10, 2025 - 04:44 PDT

Investigating

Some users are unable to login to GetFeedback Direct. We are currently investigating this issue.
Posted Jun 10, 2025 - 04:26 PDT
This incident affected: Marketing Site.