Dashboards and Survey Responses not displaying
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 17:44 PDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 17:44 PDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 17:42 PDT
Investigating
We are currently experiencing technical issues displaying dashboards and survey responses at the moment. Our engineers are currently troubleshooting this and we are still collecting responses. There should not be any data loss or misses.

Thanks for your patience as we look into this further!
Posted Apr 09, 2021 - 12:56 PDT
This incident affected: Survey Builder & Administration.