Campaign overview page not loading + API timeout errors
Incident Report for GetFeedback
Resolved
After closely monitoring today, we are happy to report we believe the issue has been addressed. All features have been enabled for all costumers this morning. Thank you for your patience while we addressed this issue.
Posted Dec 07, 2022 - 10:35 PST
Monitoring
We are seeing almost no errors and very snappy performance for the last while. Public API performance has also been consistently stable.
We’ll continue to monitor for a while before officially closing the incident, but we’re cautiously optimistic that we’ve resolved the issue.
Posted Dec 07, 2022 - 04:01 PST
Identified
A potential root cause for the disruption has been found and we are coordinating with our vendors to remedy the situation.
We’re no longer seeing high error rates, and performance is satisfactory.
The Public API has some slightly degraded performance but is functional.
The total metrics in the campaigns overview page is currently still unavailable, which show the totals as zero in the list and activity chart (customers can see these by clicking into each campaign).
We will update with more information when we the remediation changes have been applied
Posted Dec 06, 2022 - 06:50 PST
Update
We have re-enabled our public API and are monitoring to see the effects of the latest changes to address the issue.
Posted Dec 05, 2022 - 07:58 PST
Update
In an effort to further pinpoint the issue, we are temporarily turning off Public API to measure impact . Will be monitoring and turning it back on shortly.
Posted Dec 05, 2022 - 06:03 PST
Investigating
After monitoring over the weekend, it appears our efforts have slightly improved performance. We continue to investigate the issue and work with our vendor to address the degraded performance.
Posted Dec 05, 2022 - 04:05 PST
Update
We've deployed another improvement in an effort to further reduce the slowness and are monitoring to ensure stability.
Posted Dec 02, 2022 - 04:45 PST
Update
We deployed an updated version of the Public API which should improve performance and stability. We continue to work with our vendor to fully address the issue
Posted Dec 02, 2022 - 03:45 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 02, 2022 - 01:41 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 02, 2022 - 01:38 PST
Monitoring
We are seeing improvements in the performance and are monitoring to ensure stability, however issue is still present. We will update once the issue has been fully resolved.
Posted Dec 02, 2022 - 01:37 PST
This incident affected: GetFeedback Digital (formerly Usabilla) for Websites and GetFeedback Digital (formerly Usabilla) for Apps.