GetFeedback Direct home page not loading
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted Feb 09, 2022 - 13:49 PST
Identified
We are currently experiencing a technical issue where users are unable to visit app.getfeedback.com/home. The current workaround is for users to navigate directly to app.getfeedback.com/surveys

Our team is has identified the issue and are working to restore full service. Survey data, distribution, and collection are not affected.
Posted Feb 09, 2022 - 13:40 PST
This incident affected: Survey Builder & Administration.