Loading issues with results and dashboards
Incident Report for GetFeedback
Resolved
All data is restored.
Posted Jul 02, 2024 - 12:02 PDT
Monitoring
Some data has been restored and is now available to view. Engineering is actively working towards remediation and resolution to the issue.
Posted Jul 02, 2024 - 10:46 PDT
Identified
Users unable to view survey responses on their dashboards during this period
Posted Jul 02, 2024 - 10:41 PDT
Investigating
We’re investigating an issue impacting the ability to view results on the GetFeedback platform.
Posted Jul 02, 2024 - 09:21 PDT
This incident affected: Survey Builder & Administration.