Loading issues with results and dashboards

Incident Report for GetFeedback

Resolved

This incident has been resolved and results are now loading in the GetFeedback platform.
Posted Jun 17, 2024 - 11:45 PDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2024 - 11:37 PDT

Investigating

We’re investigating an issue impacting the ability to view results on the GetFeedback platform.
Posted Jun 17, 2024 - 05:22 PDT
This incident affected: Survey Builder & Administration.