Automated Email Delay
Incident Report for GetFeedback
Resolved
The issue has been resolved.
Posted May 24, 2019 - 10:50 PDT
Monitoring
Our sending partner has resolved their issue and we are in the midst of going through our data to make sure all emails are sent out properly. Thank you for your patience.
Posted May 23, 2019 - 23:27 PDT
Identified
We have identified email sending delays with the "Automate with GetFeedback Using Salesforce" feature due to an ongoing incident at our sending partner. Emails may be delayed but will send - there is no need to resend any emails. Our team is monitoring the situation and we will update our status page as soon as we hear of a resolution. Please note: this does not affect our bulk email sender, the "Send to a List with GetFeedback" feature. If you have any questions, feel free to reach out to our support team at help@getfeedback.com
Posted May 23, 2019 - 16:10 PDT
This incident affected: Email Deliverability.