GetFeedback Direct survey responses, dashboards, and email deliverability performance issues

Incident Report for GetFeedback

Resolved

This incident has been resolved.
Posted Jul 06, 2022 - 15:18 PDT

Identified

We have identified the issue and are currently deploying a fix. Email deliverability and Workspaces are currently fully operational. Survey dashboards are still experiencing degraded performance.
Posted Jul 06, 2022 - 12:34 PDT

Investigating

GetFeedback Direct survey responses, dashboards, and email deliverability services are currently experience degraded performance. Our Engineering team is currently investigating.
Posted Jul 06, 2022 - 10:14 PDT
This incident affected: Survey Builder & Administration, Email Deliverability, and GetFeedback Workspaces.