Intermittent issues with page loading/access in GetFeedback
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 14:06 PDT
Update
We are continuing to investigate this issue.
Posted Oct 30, 2023 - 14:05 PDT
Investigating
We are currently investigating this issue.
Posted Oct 30, 2023 - 13:33 PDT
This incident affected: GetFeedback Digital (formerly Usabilla) for Websites, GetFeedback Digital (formerly Usabilla) for Apps, GetFeedback Digital (formerly Usabilla) For Email, and GetFeedback Workspaces.