Loading issues with results and dashboards
Incident Report for GetFeedback
Resolved
This incident has been resolved.
Posted Jul 03, 2024 - 13:07 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 03, 2024 - 12:34 PDT
Investigating
We're investigating an issue impacting the ability to view results on the GetFeedback platform.
Posted Jul 03, 2024 - 12:09 PDT
This incident affected: Survey Builder & Administration.