Issue Logging Into Getfeedback
Incident Report for GetFeedback
Resolved
The issue has been resolved, users should be able to log into their accounts without issue. Apologies for the interruption.
Posted Apr 26, 2022 - 13:28 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2022 - 13:27 PDT
Update
Login issues have been corrected and credentials are now working as expected.
Posted Apr 26, 2022 - 13:26 PDT
Identified
We are aware of some users experiencing issues when trying to change their login credentials for GetFeedback. We have identified the issue and are currently working on addressing. Apologies for the inconvenience
Posted Apr 26, 2022 - 10:17 PDT
This incident affected: Survey Builder & Administration.